Monday, September 26, 2016

Eachine ProDVR review (Part1)

I have received Eachine ProDVR from Banggood for testing/review pruposes. I have started to test it but come up to a problem with ProDVR. I plugged Video In source (camera) and I’ve got no camera picture on the DVR output. Double checked the wirings, but still no camera video on the DVR out! I can get into settings menu, start recording, but without video In. In theory video inputs/outputs should have 75Ohm impedance (resistance to Ground). I have checked the resistance with multimeter and Video In has zero Ohms:
Name: 20160725_091751.jpg
Views: 22
Size: 886.4 KB

Meanwhile Video Out has 75Ohm resistance as it should be:
Name: 20160725_091858.jpg
Views: 19
Size: 902.7 KB

Something is not right with unit I have received!
I decided to open and inspect the ProDVR device. After inspection I’ve noticed that some SMD components are misaligned on the board and one component is totally misplaced and probably the reason of the unit failure:
Name: 20160724_174947.jpg
Views: 82
Size: 428.4 KB

I have informed Banggood about this issue. How I’m waiting for the solution from their side. I cannot finish the review without a working unit.
So much about quality issues.
To be continued...


  1. My Video Out has only 52Ohm resistance. Is that the reason that I dont have video out signal?

    1. It looks suspicious. My Video Out on various boards have ~ 70 Ohms. This could indicate some troubles. CInspect the soldering work with magnifying glass. Look for misplaced or unsoldered components. If you fail finding the reason, then make a video about the problema and post it to customer support. They should send you the replacement one.


Featured Post

Racerstar RF2205 (RF2205S) motor review and thrust test

   I have recently  received  a set of Racerstar RF2205 2300Kv motors  from Banggood  for a review . Motors came well packed in a carton...